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[bookmark: _Toc183084578]Course Objectives:
· Enhance participants’ proficiency in using Microsoft Excel beyond basic functions.
· Introduce advanced data manipulation, analysis, and visualization techniques.
· Provide hands-on practice to reinforce learning and confidence.

Important Note: This course assumes the participant already has familiarity with basic Excel functions and formulas.


[bookmark: _Toc183084579]Review of Basic Excel Skills
This course is Level 2 Excel – we’re assuming you are already comfortable with the basics. Here’s a quick review. Please complete the short activity at the end of this section to ensure you are ready to move to Level 2. 
[bookmark: _Toc183084580]Excel Interface Overview
· Workbook: The entire Excel file you are working in.
· Worksheet: Individual tabs within the workbook where you input data. You can add, delete, and rename these tabs.
· Ribbon: The toolbar at the top with tabs like Home, Insert, Page Layout, etc., each containing specific tools.
· Cells: The intersection of rows and columns. Identified by a cell reference (e.g., A1, B2).
· Formula Bar: Located above the worksheet, displays the contents or formula of the currently selected cell.
· Name Box: Displays the cell reference or the name of the selected cell or range.
· Status Bar: At the bottom of the Excel window, shows summary information like average, count, and sum of selected cells.
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[bookmark: _Toc183084581]Basic Formulas
· Addition: =A1 + B1 – Adds the values in cells A1 and B1.
· Subtraction: =A1 - B1 – Subtracts the value in cell B1 from A1.
· Multiplication: =A1 * B1 – Multiplies the values in cells A1 and B1.
· Division: =A1 / B1 – Divides the value in cell A1 by B1.
· SUM: =SUM(A1:A10) – Adds all values in the range from A1 to A10.
· AVERAGE: =AVERAGE(A1:A10) – Calculates the average of the values in the range from A1 to A10.
[bookmark: _Toc183084582]Basic Formatting
· Font Style: Change font type, size, and colour using options in the Home tab.
· Cell Borders: Add or adjust borders around cells from the Home tab.
· Cell Fill Colour: Use the Fill Colour tool to change the background color of cells.
· Text Alignment: Adjust horizontal and vertical alignment of text within cells.
· Number Formatting: Choose different formats for numbers, such as currency, percentage, or date, from the Number Format dropdown.

	[image: Try It Now]
	Instructions: Open a new blank workbook and complete the following tasks. 


1. Interface Exploration: Open a new workbook and locate the Ribbon, Formula Bar, Name Box, and Status Bar.
2. Basic Formulas: In a new worksheet, enter data into cells A1 through A5, and practice using basic formulas to sum, average, and perform arithmetic operations on these cells.
3. Formatting: Format a range of cells by changing the font style, adding borders, adjusting alignment, and applying conditional formatting based on the values.
4. Create a basic bar chart of your data
5. Do you know how to change the names and colours of the Sheet Tabs?
6. Do you know how to save and print the worksheet?
If you’ve had difficulty with any of these tasks, please review Level 1 Excel before proceeding. 



[bookmark: _Toc183084583]Advanced Functions and Formulas
[bookmark: _Toc183084584]Using logical functions (IF, AND, OR).
Introduction to Logical Functions
· IF Function: Checks whether a condition is met and returns one value if true and another if false.
· AND Function: Returns TRUE if all conditions are true; otherwise, returns FALSE.
· OR Function: Returns TRUE if any condition is true; otherwise, returns FALSE.

To start, open a new blank workbook and type the following so you can practice as we work through the examples:
[image: ]
Using the IF Function
Purpose: To perform a logical test and return one value if true and another if false.
Syntax: =IF(logical_test, value_if_true, value_if_false)
Steps:
1. Select the Cell: Click on the cell where you want to display the result.
2. Enter the Formula: Type =IF(.
3. Define the Logical Test: Specify the condition you want to test (e.g., A1 > 10).
4. Enter Value If True: Specify what to display if the condition is true (e.g., "Pass").
5. Enter Value If False: Specify what to display if the condition is false (e.g., "Fail").
6. Close the Formula: Type ) and press Enter.
Example: =IF(A1 > 10, "Pass", "Fail")

Using the AND Function
Purpose: To check if multiple conditions are all true.
Syntax: =AND(condition1, condition2, ...)
Steps:
1. Select the Cell: Click on the cell where you want the result.
2. Enter the Formula: Type =AND(.
3. Enter Conditions: Specify each condition separated by commas (e.g., A1 > 10, B1 < 5).
4. Close the Formula: Type ) and press Enter.
Example: =AND(A1 > 10, B1 < 5) will return TRUE if both conditions are met, otherwise FALSE.

Combining IF with AND/OR
Purpose: To use logical functions within the IF function for more complex conditions.
Syntax with AND: =IF(AND(condition1, condition2, ...), value_if_true, value_if_false)
Syntax with OR: =IF(OR(condition1, condition2, ...), value_if_true, value_if_false)
Steps for AND:
1. Select the Cell: Click on the cell where you want the result.
2. Enter the Formula: Type =IF(AND(.
3. Define Conditions: Enter the conditions separated by commas.
4. Enter Values: Specify what to return if all conditions are true or false.
5. Close the Formula: Type )) and press Enter.
Example with AND: =IF(AND(A1 > 10, B1 < 5), "OK", "Not OK")
Steps for OR:
1. Select the Cell: Click on the cell where you want the result.
2. Enter the Formula: Type =IF(OR(.
3. Define Conditions: Enter the conditions separated by commas.
4. Enter Values: Specify what to return if any condition is true or false.
5. Close the Formula: Type )) and press Enter.
Example with OR: =IF(OR(A1 > 10, B1 < 5), "Check", "Normal")
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	Complete the following tasks. 


1. IF Function: In cell C1, type =IF(B1 >= 100, "Qualified", "Not Qualified").
2. AND Function: In cell C2, type =AND(A1 > 50, B1 < 20). Use this in a conditional formatting rule or as part of a larger IF statement.
3. OR Function: In cell C3, type =OR(A1 < 10, B1 > 100).
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Try changing the numbers and combining these functions in different scenarios to understand their behaviour and usage.

[bookmark: _Toc183084585]Using lookup and reference functions (VLOOKUP, HLOOKUP, INDEX, MATCH).
Lookup and reference functions in Excel are used to retrieve data from various parts of a spreadsheet and to organize or navigate through large datasets efficiently. Here’s a breakdown of their purposes and some common functions in each category:
[bookmark: _Toc183084586]Lookup Functions
Purpose: Lookup functions are designed to search for a value in a table or range and return a corresponding value from another column or row. They are particularly useful for finding data in large datasets.
Common Lookup Functions:
· VLOOKUP (Vertical Lookup):
· Usage: Searches for a value in the first column of a range and returns a value in the same row from a specified column.
· Syntax: =VLOOKUP(lookup_value, table_array, col_index_num, [range_lookup])
· Example: =VLOOKUP(A2, B2:D10, 3, FALSE) searches for the value in cell A2 within the range B2
and returns the value from the third column in the row where the match is found.
· HLOOKUP (Horizontal Lookup):
· Usage: Searches for a value in the first row of a range and returns a value in the same column from a specified row.
· Syntax: =HLOOKUP(lookup_value, table_array, row_index_num, [range_lookup])
· Example: =HLOOKUP(B1, A2:D5, 4, TRUE) searches for the value in cell B1 within the range A2
and returns the value from the fourth row in the column where the match is found.
· LOOKUP:
· Usage: Looks up a value in a vector or array and returns a corresponding value from another vector or array. Can be used in either vector or array forms.
· Syntax (Vector Form): =LOOKUP(lookup_value, lookup_vector, [result_vector])
· Example: =LOOKUP(2, A1:A10, B1:B10) looks for the number 2 in the range A1 and returns the corresponding value from the range B1
	[image: Try It Now]
	Complete the following tasks: 

Create the following two tables in an Excel worksheet 

Table 1: Product Table (Reference Table)
	Product ID
	Product Name
	Price
	Stock

	P001
	Smartphone
	500
	120

	P002
	Laptop
	1200
	50

	P003
	Headphones
	100
	200

	P004
	Smartwatch
	250
	80

	P005
	Tablet
	600
	75



Table 2: Sales Data Table
	Order ID
	Product ID
	Product Name
	Price

	1001
	P003
	
	

	1002
	P001
	
	

	1003
	P005
	
	

	1004
	P004
	
	

	1005
	P002
	
	



1. In the Sales Data Table, use the VLOOKUP formula to:
· Fetch the Product Name based on the Product ID from the Product Table.
· Fetch the Price based on the Product ID from the Product Table.
2. Formula for Product Name:
In Cell C2, enter: =VLOOKUP(B2, $A$2:$D$6, 2, FALSE)

This searches for the Product ID in column A of the reference table and retrieves the Product Name from column 2.

3. Formula for Price:
In Cell D2, enter: =VLOOKUP(B2, $A$2:$D$6, 3, FALSE)

This retrieves the price from column 3 of the reference table.

4. Drag the formulas down to fill the remaining rows in the Sales Data Table.




[bookmark: _Toc183084587]Reference Functions
Purpose: Reference functions are used to create, manage, and navigate ranges of cells. They allow for dynamic references to different parts of a spreadsheet and facilitate complex calculations and data analysis.
Common Reference Functions:
· INDEX:
· Usage: Returns the value of a cell in a given range based on row and column numbers.
· Syntax: =INDEX(array, row_num, [column_num])
· Example: =INDEX(A1:C10, 2, 3) returns the value from the cell in the second row and third column of the range A1
[image: ]
· MATCH:
· Usage: Searches for a value in a range and returns the relative position of that item.
· Syntax: =MATCH(lookup_value, lookup_array, [match_type])
· Example: =MATCH("Apple", B1:B10, 0) searches for "Apple" in the range B1 and returns its position within that range.
	
[image: Try It Now]
	Complete the following tasks based on the same data as the previous activity: 

In this task, you will find the row positions of product IDs in the Product Table using the MATCH function. You will then use these positions to identify how MATCH can complement functions like INDEX or VLOOKUP.

Add a new column to the Sales Data Table . Modify the Sales Data Table to include a column for the Product Position.

Updated Table: Sales Data Table
	Order ID
	Product ID
	Product Name
	Price
	Product Position

	1001
	P003
	(Use VLOOKUP)
	(Use VLOOKUP)
	(Use MATCH)

	1002
	P001
	(Use VLOOKUP)
	(Use VLOOKUP)
	(Use MATCH)

	1003
	P005
	(Use VLOOKUP)
	(Use VLOOKUP)
	(Use MATCH)

	1004
	P004
	(Use VLOOKUP)
	(Use VLOOKUP)
	(Use MATCH)

	1005
	P002
	(Use VLOOKUP)
	(Use VLOOKUP)
	(Use MATCH)



Instructions
1. Find Product Position:
In Column E, use the MATCH function to find the position of each Product ID from the Product Table.
2. Formula for Product Position:
In Cell E2, enter: =MATCH(B2, $A$2:$A$6, 0)
· B2 is the Product ID from the Sales Data Table.
· $A$2:$A$6 is the column of Product IDs in the Product Table.
· 0 specifies an exact match.
3. Drag the formula down to fill the remaining rows in Column E.

4. Use MATCH to find the row of the Product ID and INDEX to retrieve the Product Name from the Product Table.
5. Example formula in Cell C2: =INDEX($B$2:$B$6, MATCH(B2, $A$2:$A$6, 0))






[bookmark: _Toc183084588]Introduction to array formulas.
Array formulas in Microsoft Excel are powerful tools that enable you to perform complex calculations and manipulate data in ways that standard formulas cannot. Unlike regular formulas that handle single values, array formulas can process multiple values simultaneously, making them ideal for tasks that involve arrays or ranges of data.
An array formula is a type of formula that performs calculations on a range of cells, known as an array, rather than on a single cell. It can return either a single result or multiple results, depending on how it’s set up. Array formulas can be used for a variety of purposes, such as:
· Performing Calculations on Multiple Cells: Applying a calculation to each element in a range and returning a single result.
· Aggregating Data: Summarizing or analysing data across multiple cells.
· Creating Dynamic Ranges: Generating ranges of values based on specific criteria.
[bookmark: _Toc183084589]How Array Formulas Work
Array formulas operate on arrays of values, which can be either:
· A Single Range: For instance, performing a calculation on every cell in a column.
· Multiple Ranges: For instance, comparing values across different columns.
Array formulas can be used with different types of functions, including mathematical operations, text functions, and logical functions. They are often used with functions like SUM, AVERAGE, IF, and INDEX, among others, to extend their capabilities.
Creating and Using Array Formulas
1. Simple Array Formula:
· Example: To sum the squares of numbers in cells A1 through A5, you can use: =SUM(A1:A5^2).
· Entering the Formula: Press Ctrl + Shift + Enter instead of just Enter to confirm the formula. Excel will automatically enclose the formula in curly braces {} to indicate that it’s an array formula.
2. Array Formula with Multiple Results:
· Example: To multiply values in cells A1 through A3 by values in cells B1 through B3 and display the results in a range, select the output range (e.g., C1
), enter the formula =A1:A3 * B1:B3, and press Ctrl + Shift + Enter.
3. Dynamic Array Functions (Excel 365 and Excel 2019):
· Example: The FILTER function returns an array that filters data based on criteria. For example, =FILTER(A1:B10, A1:A10 > 50) returns all rows where the value in column A is greater than 50.
· No Special Keystrokes Needed: Modern versions of Excel handle dynamic arrays automatically without requiring Ctrl + Shift + Enter.
Common Array Formula Functions
· SUMPRODUCT: Multiplies corresponding components in given arrays and returns the sum of those products. Example: =SUMPRODUCT(A1:A5, B1:B5).
· TRANSPOSE: Converts rows to columns and vice versa. Example: =TRANSPOSE(A1:A10).
· MMULT: Multiplies two matrices. Example: =MMULT(A1:B2, C1:D2).
[image: SUMPRODUCT function - Microsoft Support]
Advantages of Array Formulas
· Efficiency: They can handle complex calculations with fewer formulas.
· Flexibility: Suitable for calculations that involve multiple cells and ranges.
· Dynamic: Particularly useful in creating dynamic reports and analyses that adjust as data changes.
Considerations
· Performance: Complex array formulas can impact performance, especially with large datasets.
· Error Handling: If an array formula returns an error, ensure all array dimensions and criteria are correctly specified.
Array formulas in Excel provide a robust and flexible way to perform advanced calculations and data manipulations. By understanding how to create and use array formulas, you can significantly enhance your data analysis and reporting capabilities in Excel. Whether working with large datasets or complex calculations, array formulas can simplify tasks and provide powerful insights.
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	Complete the following tasks. 
In this task, you will utilize array functions to dynamically retrieve and organize data from the Product Table and create a filtered, sorted, unique list of products based on specific criteria. Setup the Product Table: 
	Product ID
	Product Name
	Price
	Stock

	P001
	Smartphone
	500
	120

	P002
	Laptop
	1200
	50

	P003
	Headphones
	100
	200

	P004
	Smartwatch
	250
	80

	P005
	Tablet
	600
	75



Task 1: Filter Products by Stock Level
Use the FILTER function to display products with a stock level below 100. In a new section of the worksheet, enter: =FILTER(A2:D6, D2:D6 < 100, "No products below stock threshold")
· A2:D6: The entire Product Table.
· D2:D6 < 100: Condition to filter products where stock is below 100.
· "No products below stock threshold": A message displayed if no products meet the criteria.
Expected Output:
	Product ID
	Product Name
	Price
	Stock

	P002
	Laptop
	1200
	50

	P005
	Tablet
	600
	75



Task 2: Sort Products by Price
Use the SORT function to display the Product Table in ascending order of price. In a new section, enter: =SORT(A2:D6, 3, 1)
· A2:D6: The entire Product Table.
· 3: The column index for "Price".
· 1: Sort order (1 for ascending, -1 for descending).
Expected Output:
	Product ID
	Product Name
	Price
	Stock

	P003
	Headphones
	100
	200

	P004
	Smartwatch
	250
	80

	P001
	Smartphone
	500
	120

	P005
	Tablet
	600
	75

	P002
	Laptop
	1200
	50



Task 3: Create a Unique List of Products
Use the UNIQUE function to create a list of unique product names from the Product Table. In a new section, enter: =UNIQUE(B2:B6)
1. Expected Output:
	Product Name

	Smartphone

	Laptop

	Headphones

	Smartwatch

	Tablet






[bookmark: _Toc183084590]Data Management Techniques
[bookmark: _Toc183084591]Data validation to control data entry (drop-down lists, input messages, error alerts).
Data validation in Excel is a powerful feature that helps ensure the accuracy and consistency of data entered into your spreadsheets. It allows you to set specific rules and restrictions for what can be entered into cells. This guide covers how to use data validation to create drop-down lists, input messages, and error alerts. 
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1. Creating Drop-Down Lists
Purpose: Drop-down lists restrict users to selecting from a predefined set of values, reducing the risk of entry errors and standardizing data input.
1. Select the Cells:
· Click on the cell or range of cells where you want the drop-down list to appear.
2. Open Data Validation:
· Go to the Data tab on the Ribbon.
· Click Data Validation in the Data Tools group.
· In the Data Validation dialog box, go to the Settings tab.
3. Configure the Drop-Down List:
· In the Allow dropdown menu, select List.
· In the Source box, enter the list of values you want to appear in the drop-down list. Separate each value with a comma (e.g., Apple, Banana, Orange).
· Alternatively, if you have a range of cells with the list values, click the Source box and select the range from your worksheet.
· Finish and Apply: Click OK to create the drop-down list.
Example: A cell with a drop-down list allows users to choose between "Yes," "No," and "Maybe."
	[image: Try It Now]
	Complete the following tasks. 
Enable users to select Product IDs from a predefined list instead of typing them manually.
1. Open the "Sales Data Table" sheet in the Excel file.
2. Select cells in Column B under Product ID (e.g., B2:B6).
3. Go to the Data tab → Data Validation → Data Validation.
4. In the Settings tab:
· Allow: List.
· Source: $A$2:$A$6 (Product IDs from the "Product Table").
· Click OK and you will see a drop-down arrow in each selected cell in Column B, showing all available Product IDs.




2. Adding Input Messages
Purpose: Input messages provide users with guidance on what type of data is expected in a cell. They appear when a cell is selected, helping to prevent data entry errors.
Steps:
1. Select the Cells:
· Click on the cell or range of cells where you want to add an input message.
2. Open Data Validation:
· Go to the Data tab on the Ribbon.
· Click Data Validation in the Data Tools group.
· In the Data Validation dialog box, go to the Input Message tab.
3. Configure the Input Message:
· Check the box for Show input message when cell is selected.
· Enter a title and message in the respective fields. The title appears as a heading in the input message box, and the message provides instructions.
4. Finish and Apply:
· Click OK to save the input message settings.
Example: An input message might say "Enter a date in the format YYYY-MM-DD" when a user selects a cell designated for date input.
[image: ]
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	Complete the following tasks. 
Display a tooltip to guide users when they select cells in Column B (Product ID).
1. Follow steps 1-3 above.
2. In the Data Validation dialog, go to the Input Message tab.
3. Check Show input message when cell is selected.
4. Enter:
· Title: Select Product ID
· Input Message: Choose a Product ID from the list provided.
· Click OK and now, when a user selects a cell in Column B, a small message box will appear with the provided input message.



3. Setting Up Error Alerts
Purpose: Error alerts prevent users from entering invalid data by displaying an alert message when they attempt to enter data that doesn’t meet the specified validation criteria.
1. Select the Cells:
· Click on the cell or range of cells where you want to apply the error alert.
· Open Data Validation: Go to the Data tab on the Ribbon. Click Data Validation in the Data Tools group.In the Data Validation dialog box, go to the Error Alert tab.
2. Configure the Error Alert:
· Check the box for Show error alert after invalid data is entered.
· Choose the Style of the alert: Stop (prevents entry of invalid data), Warning (allows the user to proceed but warns them), or Information (provides a non-intrusive alert). Enter a title and error message. The title appears in the error alert dialog box, and the message describes the nature of the error and provides corrective advice.
· Finish and Apply: Click OK to apply the error alert settings.
Example: If a cell is set to accept only dates, a custom error alert might say "Invalid entry! Please enter a date in the format YYYY-MM-DD."
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	Complete the following tasks. 
Prevent users from entering invalid Product IDs and show a custom error message.
1. Follow steps 1-3 from the drop-down list activity.
2. In the Data Validation dialog, go to the Error Alert tab.
3. Check Show error alert after invalid data is entered.
4. Enter:
· Style: Stop (prevents invalid entries).
· Title: Invalid Product ID
· Error Message: You must select a Product ID from the list.
· Click OK and now If a user types a Product ID not in the list, they will see the error message and cannot proceed.



[bookmark: _Toc183084592]Using named ranges for easier formula creation and management.
Named ranges in Excel are a feature that allows you to assign a meaningful name to a cell or range of cells. This makes working with formulas, data management, and navigation more intuitive and efficient. Here’s a comprehensive guide on how to use named ranges to simplify formula creation and management:
1. What Are Named Ranges?
Named Ranges: A named range is a cell or a range of cells that is assigned a name, making it easier to reference in formulas and other operations. Instead of using cell references like A1:C6, you use a name like SalesData or Stock.
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2. Creating Named Ranges
1. Select the Cell or Range:
· Click on the cell or drag over the range of cells that you want to name.
2. Define the Name:
· Using the Name Box:
· Click on the Name Box (the box to the left of the formula bar). Type the desired name for the range (e.g., Stock) and press Enter.
· Using the Define Name Dialog:
· Go to the Formulas tab on the Ribbon. Click Define Name in the Defined Names group.
· In the New Name dialog box, enter a name, optionally provide a description, and ensure the correct cell or range is displayed in the Refers to box. Click OK to create the named range.
Naming Rules:
· Must begin with a letter or underscore.
· Cannot contain spaces.
· Should not be a reserved word or conflict with cell references.
· Should be descriptive and meaningful. Example: Name a range of cells containing sales data as SalesData to easily reference it in formulas.


3. Using Named Ranges in Formulas
Benefits:
· Readability: Named ranges make formulas easier to read and understand.
· Ease of Use: Reduces the likelihood of errors in cell references.
Steps:
1. Referencing Named Ranges:
· When entering a formula, you can use the name of the range directly instead of cell references.
· Example: Instead of =SUM(A1:A10), use =SUM(SalesData) if you named the range SalesData.
2. Editing Named Ranges:
· To Edit: Go to the Formulas tab, click Name Manager, select the name, and click Edit.
· To Delete: In the Name Manager, select the name and click Delete.
Example: If you have a named range DiscountRates, you can use it in a formula like =A1 * DiscountRates instead of specifying cell ranges.
4. Managing Named Ranges
The Name Manager is accessed via the Formulas tab by clicking Name Manager. It provides a centralized location to view, edit, delete, and manage all named ranges in the workbook.
Steps:
1. Open Name Manager:
· Go to the Formulas tab.
· Click Name Manager.
2. View and Edit Named Ranges:
· In the Name Manager dialog box, you can see a list of all named ranges.
· Select a name to view details or make changes.
· Click Edit to modify the range or its name.
· Click Delete to remove a name.
Example: If SalesData is no longer valid, you can update it in the Name Manager to point to a new range or delete it if it’s no longer needed.
5. Benefits of Using Named Ranges
· Improved Formula Clarity: Named ranges make formulas more understandable.
· Simplified Range Management: Easily adjust or update named ranges without modifying multiple formulas.
· Error Reduction: Minimize errors caused by incorrect cell references.
· Enhanced Navigation: Quickly navigate to named ranges using the Name Box.
Example: In a financial model, named ranges like TotalRevenue and OperatingExpenses can be used in formulas like =TotalRevenue - OperatingExpenses to calculate net profit clearly.
	[image: Try It Now]
	Complete the following tasks. 

1. Create Named Ranges
Use the "Product Table" sheet to define named ranges for the table columns.
1. Open the "Product Table" sheet.
2. Select Column A (Product IDs) from A2:A6.
· Go to the Formulas tab → Define Name.
· Name the range ProductIDs.
3. Repeat for other columns:
· Column B (Product Names): Name it ProductNames.
· Column C (Prices): Name it Prices.
· Column D (Stock): Name it StockLevels.

2. Use Named Ranges in Formulas
Simplify VLOOKUP Using Named Ranges
In the "Sales Data Table" sheet, replace standard cell references in VLOOKUP formulas with named ranges.
· Example:
Fetch Product Name (Column C) using:
=VLOOKUP(B2, ProductTable, 2, FALSE)
Steps:
1. Select the entire Product Table (A2:D6) and name it ProductTable.
2. In Cell C2 of the "Sales Data Table," enter:
=VLOOKUP(B2, ProductTable, 2, FALSE)
3. Drag the formula down.

Use Named Ranges with SUMIF
Calculate the total stock for all products priced above 500 using SUMIF.
1. In a new cell (e.g., F2), enter: =SUMIF(Prices, ">500", StockLevels)
2. This formula sums stock levels for products whose prices are greater than 500.

3. Combine Named Ranges with MATCH
Find the row position of a specific product (e.g., P003) in the "Product Table."
1. In a new cell (e.g., G2), enter:
=MATCH("P003", ProductIDs, 0)
2. This returns the position of the product P003 within the named range ProductIDs.




[bookmark: _Toc183084593]PivotTables and PivotCharts
[bookmark: _Toc183084594]Creating and customizing PivotTables.
PivotTables are powerful tools in Excel used to summarize, analyze, and visualize large datasets quickly. They allow users to organize data into a table format by dragging and dropping fields, enabling flexible data exploration.
Steps to Create a PivotTable
1. Prepare the Dataset
Ensure your data is in a structured format with:
· Columns having headers.
· No blank rows or columns.
2. Insert a PivotTable
· Select the dataset (e.g., A1:D6 in the "Sales Data Table").
· Go to the Insert tab → PivotTable.
· In the dialog box:
· Choose where to place the PivotTable (New or Existing Worksheet).
· Click OK.
3. Build the PivotTable
· A blank PivotTable appears, along with the PivotTable Fields pane.
· Drag fields into the following areas:
· Rows: To group data (e.g., Product Name).
· Columns: To create column headers (e.g., Order ID).
· Values: To summarize data (e.g., sum of Price).
· Filters: To filter data (e.g., Product ID).
4. Customize the PivotTable
· Summarize Values: Right-click a value field → Summarize Values By (Sum, Count, Average, etc.).
· Sort and Filter: Use dropdowns in Rows or Columns to sort and filter data.
· Format Values: Right-click on values → Number Format to adjust formatting (e.g., currency).
5. Add PivotTable Styles
· Select the PivotTable → Go to PivotTable Analyze or Design tab.
· Choose a style or add banded rows/columns.

[image: ]
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	Complete the following tasks. 
1. Create the PivotTable
· Select the combined dataset, including both the "Sales Data Table" and "Product Table" (you may need to combine these sheets into one table first).
· Insert a PivotTable in a new worksheet.
2. Build the PivotTable
· Add Product Name to the Rows area.
· Add Price to the Values area (summarized as Sum).
· Add Stock Levels to the Values area (summarized as Sum).
3. Filter the Data
· Drag Product ID to the Filters area.
· Filter the PivotTable to show data for specific Product IDs (e.g., P001 and P002).
4. Customize the PivotTable
· Sort the Product Names alphabetically.
· Format the Price and Stock Level values as currency and numbers, respectively.
· Apply a PivotTable style with banded rows.

The PivotTable should display:
· A list of products in the rows.
· Total prices for each product in one column.
· Total stock levels for each product in another column.






[bookmark: _Toc183084595]Analyzing data with PivotCharts.
PivotCharts are visual representations of data from PivotTables. They allow you to quickly summarize and visualize trends and patterns in your data. You can create a PivotChart directly from an existing PivotTable, which makes it easier to analyze and present your data interactively.
1. Prepare Your Dataset
Ensure your data is organized in a table format with clear headers and no empty rows or columns. For example, in our previous "Sales Data Table," we had fields like Product Name, Price, and Stock Levels.
2. Create a PivotTable
Before creating a PivotChart, you first need to create a PivotTable (as described earlier).
3. Insert a PivotChart -Once the PivotTable is created:
1. Click anywhere inside the PivotTable to make sure it's active.
2. Go to the Insert tab on the Excel ribbon.
3. In the Charts group, click on the PivotChart button.
4. Select the type of chart you want (Column, Line, Pie, etc.).
5. Click OK to insert the chart.

4. Customize the PivotChart
After inserting the PivotChart, you can customize it to improve readability and presentation.
Steps to customize the chart:
· Change Chart Type: Right-click on the chart → Change Chart Type → Select the chart type (e.g., Bar, Line, Pie).
· Add or Remove Data Series: Use the Chart Fields pane to drag different fields into the Values or Axis area to modify how data is visualized.
· Format the Chart: Use the Chart Tools in the Ribbon (under the Design and Format tabs) to customize colours, styles, and data labels.
· Apply Filters: Apply filters or slicers to the PivotTable and the chart will automatically update based on the filtered data.
· Data Labels: Add data labels to display the exact values directly on the chart.


[bookmark: _Toc183084596]Data Analysis Tools
What-If Analysis is a powerful feature in Excel that helps you explore different scenarios and make better decisions based on varying assumptions. Excel provides several tools for performing What-If Analysis, such as Scenarios, Data Tables, and Goal Seek. These tools allow you to analyze how changes in input values affect outcomes.
Types of What-If Analysis in Excel:
1. Scenarios: Explore different sets of values for multiple variables and compare the results.
2. Goal Seek: Find the input value needed to achieve a desired output.
3. Data Tables: Analyze how one or two input variables affect a formula’s output over a range of values.
1. Using Scenarios in Excel
A Scenario is a set of input values that Excel stores and allows you to switch between easily. For example, you can create different sales scenarios for a business and compare their results.
How to Create and Use Scenarios:
1. Prepare the Data: Set up your Excel worksheet with formulas and variables that you want to analyze. For example, in a sales model, you might have formulas to calculate Total Sales, Profit Margin, and Net Profit based on input values like Unit Price, Units Sold, and Fixed Costs.
2. Define Scenarios:
· Go to the Data tab → What-If Analysis → Scenario Manager.
· In the Scenario Manager dialog box, click Add to create a new scenario.
· Name the scenario (e.g., "Best Case", "Worst Case").
· Select the cells that you want to vary in the scenario (e.g., unit price, units sold).
· Input the values for the scenario and click OK.
· Repeat to add multiple scenarios (e.g., a "Worst Case" scenario with lower unit sales, and a "Best Case" with higher sales).
3. View Scenarios:
· Once you've added your scenarios, click Show in the Scenario Manager to view how the values change when switching between scenarios.
4. Create a Scenario Summary:
· In the Scenario Manager, click Summary.
· Choose the output cell that you want to summarize (e.g., Net Profit).
· Excel will generate a summary report showing the results of all the scenarios you defined.

2. Goal Seek in Excel
Goal Seek is a tool that allows you to determine the input value required to reach a specific result. For example, you might want to know how much you need to sell in order to achieve a target profit.
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How to Use Goal Seek:
· Prepare the Data: Set up a formula that calculates a result based on input values. For example: = (Unit Price * Units Sold) - Fixed Costs
· Go to the Data tab → What-If Analysis → Goal Seek.
· In the Goal Seek dialog:
· Set the Set Cell to the cell with your formula (e.g., Net Profit).
· Set the To Value to the target value (e.g., a target profit of 10,000).
· Set the By Changing Cell to the input value (e.g., Units Sold).
· Click OK to calculate the required value.
2. Analyze the Result: Goal Seek will find the input value (Units Sold) that will result in the desired output (Net Profit).
3. Data Tables in Excel
A Data Table is a type of What-If Analysis tool that shows how changes in one or two variables affect a formula’s result. It is especially useful when you want to analyze the effect of multiple values at once.
How to Use Data Tables:
· One-Variable Data Table:
1. Set up a formula that depends on a variable (e.g., a loan repayment formula with an interest rate).
2. List a range of values for that variable (e.g., different interest rates) in one column.
3. Select the formula and the range of values.
4. Go to the Data tab → What-If Analysis → Data Table.
5. In the Data Table dialog, specify the Row Input Cell (if the variable is in a row) or Column Input Cell (if the variable is in a column).
6. Excel will populate the table with results for each value.
· Two-Variable Data Table:
1. Set up a formula with two variables.
2. List one set of input values in the row and the other set in the column.
3. Select the entire table (including the formula).
4. Go to the Data tab → What-If Analysis → Data Table.
5. Specify the row and column input cells.
6. Excel will calculate the results for all combinations of the two variables.

Introduction to Solver for Optimization Problems
Solver is a powerful Excel add-in that is used to find an optimal solution to a problem by changing multiple variables. It is typically used for optimization problems, such as maximizing profit, minimizing cost, or finding the best allocation of resources.
How to Use Solver:
1. Enable Solver Add-In:
· Go to the File tab → Options → Add-ins.
· In the Manage box, select Excel Add-ins → Click Go.
· Check Solver Add-in and click OK.
2. Set Up the Problem:
· Create a worksheet that includes the formulas you need for your optimization problem.
· Define the Objective cell, which contains the value you want to maximize or minimize (e.g., Total Profit).
· Define the Decision Variables, which are the cells that Solver will adjust (e.g., Units Sold, Price per Unit).
· Define the Constraints, which are the limitations or restrictions for the decision variables (e.g., budget, production capacity).
3. Configure Solver: 
· Go to the Data tab → Solver.
· Set the Objective to the cell with the result you want to optimize (e.g., Total Profit).
· Set the Equal to field to Max or Min depending on whether you want to maximize or minimize the result.
· Set the By Changing Variable Cells to the cells that Solver will adjust.
· Click Add to add constraints if needed (e.g., Units Sold cannot exceed available stock). Click Solve to find the optimal solution.
4. Analyze the Solution:
· Once Solver finds a solution, it will update the decision variables and provide the optimal result in the objective cell. You can review the solution and adjust the model as necessary.

[bookmark: _Toc183084597]Advanced Formatting Techniques
[bookmark: _Toc183084598]Conditional formatting with formulas.
Conditional Formatting is a powerful feature in Excel that allows you to apply formatting (like colours, fonts, or borders) to cells based on their values. Using formulas with conditional formatting gives you more flexibility and control, enabling you to apply formatting rules that go beyond simple comparisons like "greater than" or "less than."
In Excel, conditional formatting with formulas allows you to define your own criteria for when a cell's formatting should change. Instead of relying on the default rules, you can create custom formulas that evaluate the content of cells and apply formatting when certain conditions are met.
Steps to Apply Conditional Formatting with a Formula
1. Select the Range of Cells: Highlight the cells where you want to apply conditional formatting. For example, if you want to highlight sales figures above a target, select the range of cells in the sales column.
2. Open the Conditional Formatting Dialog:
· Go to the Home tab on the Excel ribbon.
· Click Conditional Formatting in the Styles group.
· Select New Rule.
3. Choose "Use a Formula to Determine Which Cells to Format":
· In the New Formatting Rule dialog, select Use a formula to determine which cells to format.
· This option allows you to input your own formula for determining which cells should be formatted.
4. Enter the Formula:
· In the formula box, enter a formula that returns TRUE or FALSE based on the condition you want to apply.
· The formula must return TRUE for the cells you want to format. For example:
· To highlight cells where the value is greater than 1000:
=A1>1000 (Assuming you are applying the rule to column A)
· To highlight cells with values less than the average of a range:
=A1<AVERAGE($A$1:$A$10)
· To format cells that are equal to a specific value: =A1="Target"
5. Set the Format:
· After entering the formula, click the Format button to choose the formatting you want (e.g., font colour, cell colour, border).
· Once you’ve selected the formatting options, click OK.
6. Finish: Click OK again to apply the rule.
The cells that meet the condition specified in your formula will now display the selected formatting.
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	Complete the following tasks. 

Example 1: Highlight Cells Greater than a Specific Value
If you want to highlight all sales figures greater than 1000:
1. Select the range of cells with the sales data (e.g., A1).
2. Enter the formula: =A1>1000
3. Choose a colour to highlight cells greater than 1000 (e.g., green).

Example 2: Highlight Cells with Text Matching Specific Criteria
To highlight cells that contain the word "Target":
1. Select the range of cells (e.g., A1).
2. Enter the formula: =A1="Target"
3. Choose a formatting style, such as a background color.

Example 3: Highlight the Top 10 Percent of Values
To highlight the top 10% of values in a list:
1. Select the range (e.g., A1).
2. Enter the formula: =A1>=PERCENTILE($A$1:$A$10,0.9)
· This formula calculates the value at the 90th percentile and formats cells greater than or equal to it.
3. Choose a format to highlight these values, such as a bold font or a colour change.






[bookmark: _Toc183084599]Protecting worksheets and workbooks.
Protecting worksheets and workbooks in Excel is a crucial step to safeguard your data and prevent unauthorized or accidental changes. By setting up protection, you can control what users can and cannot do within your workbook or worksheet. There are two main levels of protection:
· Protecting a Worksheet: This restricts the ability to edit or modify certain cells or content on a particular worksheet.
· Protecting a Workbook: This protects the entire workbook, including the structure (e.g., adding, deleting, or moving sheets) and the workbook itself (e.g., setting a password to open or modify the file).
1. Protecting a Worksheet
When you protect a worksheet, you can lock specific cells to prevent users from editing them. By default, all cells in a worksheet are locked when you protect it. You can selectively unlock certain cells to allow users to edit them.
Steps to Protect a Worksheet:
· Unlock the Cells You Want to Edit (optional):
· Select the range of cells you want to allow users to edit.
· Right-click and choose Format Cells.
· Go to the Protection tab and uncheck the Locked box.
· Click OK.
This step is essential if you want some cells to remain editable after the worksheet protection is applied.
Protect the Worksheet:
· Go to the Review tab on the ribbon.
· Click Protect Sheet.
· In the Protect Sheet dialog box, you can:
· Set a password to unprotect the sheet (optional but recommended).
· Choose the actions users are allowed to perform (e.g., select locked cells, format cells, insert rows, etc.). You can leave everything unchecked to prevent any editing.
· Click OK.
If you set a password, Excel will ask you to confirm it. Enter the password again and click OK. Now, users cannot make changes to the locked cells unless they unprotect the sheet (and provide the password, if set).
How to Unprotect a Worksheet:
To unprotect a worksheet, go to the Review tab, click Unprotect Sheet, and if a password was set, enter it.
2. Protecting a Workbook
Protecting a workbook prevents users from making structural changes, such as adding, deleting, or renaming sheets. Additionally, you can password-protect the entire workbook, so only authorized users can open or modify it.
Steps to Protect the Workbook Structure:
· Go to the Workbook Protection Option:
· Go to the Review tab on the ribbon.
· Click Protect Workbook.
· In the Protect Workbook dialog box, you can:
· Set a password to prevent unauthorized access (optional).
· Choose to protect the structure (this prevents users from adding, deleting, or moving sheets).
· Click OK.
Set a Password (optional):
· If you select the option to password-protect the workbook, Excel will ask you to set a password. Enter a password and click OK.
· Re-enter the password to confirm and click OK.
· Now, users will not be able to modify the structure of the workbook unless they unprotect it by entering the password.
How to Unprotect the Workbook:
To unprotect a workbook, go to the Review tab, click Unprotect Workbook, and if a password was set, enter it.

3. Protecting the Entire Workbook with Password
If you want to prevent users from opening or editing the entire workbook without permission, you can set a password to protect it.
Password Protect the Entire Workbook:
· Go to File → Info → Protect Workbook → Encrypt with Password.
· Enter a strong password (make sure you remember it!).
· Click OK, then re-enter the password to confirm.
· Now, users will need to provide the password to open or modify the workbook.
How to Remove Password Protection:
To remove the password, go to File → Info → Protect Workbook → Encrypt with Password, and delete the password from the dialog box. Click OK.
4. Advanced Protection Options
Excel provides advanced protection options to secure your data further, such as:
Allowing Users to Edit Specific Ranges:
If you want to protect the worksheet but allow specific users to edit certain ranges, you can:
· Select the range of cells you want to allow users to edit.
· Right-click the selection and choose Format Cells.
· Go to the Protection tab and check the Unlocked box.
· After unlocking the cells, protect the sheet, and users will be able to edit only those unlocked ranges.
Protecting the Workbook from Viewing or Printing:
You can also protect your workbook from viewing, printing, or making changes by using options in the Protect Workbook settings.
5. Limitations of Protection
Password Recovery: If you forget a password for a protected sheet or workbook, there is no built-in way to recover it in Excel. It is important to keep your passwords safe.
Security Level: While Excel’s protection features are useful, they are not intended for highly sensitive information. They provide basic protection but are not foolproof. For stronger security, consider encrypting the file with more advanced tools (e.g., Windows File Encryption).
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	Try out all of the above options on one of your workbooks! 



[bookmark: _Toc183084600]Tracking changes and comments.
Excel provides several features that help users track changes, add comments, and collaborate on documents. These features are particularly useful in a shared environment or when working with others on the same file. The two main tools for tracking changes and adding comments are Track Changes and Comments (or Notes).
Let’s look at how to use these features:
1. Track Changes in Excel
The Track Changes feature allows you to track edits made to a shared workbook. This feature highlights changes made by different users, making it easy to see who changed what and when.
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Steps to Track Changes in Excel:
· Turn on Shared Workbook (for older versions of Excel):
· Go to the Review tab on the ribbon.
· Click Share Workbook (in Excel 2016 and earlier).
· In the Share Workbook dialog box, check the option Allow changes by more than one user at the same time.
· Click OK to enable sharing, and then save the workbook.
Note: In newer versions of Excel (2019, Office 365, etc.), collaborative features like AutoSave and Excel Online are preferred for tracking changes, so you no longer need to use the "Share Workbook" option.
Track Changes:
· Go to the Review tab and click Track Changes.
· From the drop-down menu, select Highlight Changes.
· In the Highlight Changes dialog box:
· Check the box for Track changes while editing.
· Select the option When (e.g., since a specific date or since the last time the workbook was saved).
· Select the changes you want to track, such as All, Changes not yet reviewed, or Changes from everyone.
· Click OK.
Review Changes:
Excel will show a list of changes made by different users, including the date, the user’s name, the changes made, and the affected cells. You can accept or reject changes as needed. Right-click on the highlighted cell and choose Accept or Reject.
Stop Tracking Changes:
To stop tracking changes, go to Review → Track Changes → Highlight Changes and uncheck Track changes while editing. Alternatively, you can turn off sharing the workbook by going to the Review tab → Share Workbook and unchecking the sharing options.
2. Comments and Notes in Excel
Comments (or Notes in newer versions) allow you to add explanatory text to cells. This is particularly helpful for leaving feedback or instructions for others.
Adding Comments (Notes):
In Excel 2016 and earlier, Comments were used. In later versions (Excel 365 and 2019), these are referred to as Notes, while Comments now allow threaded conversations in shared workbooks.
· Right-click on the cell where you want to add a comment or note. Select New Comment (or Insert Note in Excel 365/2019). Type your text in the comment box that appears.
· Once you finish typing, click anywhere outside the comment box to close it. The cell will display a small red triangle in the upper-right corner to indicate there is a comment.
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Formatting Comments/Notes:
· To format a comment or note, right-click the cell, then click Edit Comment or Edit Note.
· Right-click the border of the comment box and select Format Comment or Format Note.
· You can change the font, size, background color, and other formatting options.
Viewing Comments/Notes:
Hover your mouse over the cell with a comment or note to see its content. In newer versions of Excel, you can also show all comments by going to the Review tab and clicking Show All Comments.
Replying to Comments (in Excel 365/2019):
If you are using Excel Online or a version with threaded comments, you can reply to comments. Click on the comment, and a box will appear allowing you to respond to the original comment. This feature is ideal for collaboration and discussions within the Excel document itself.
Deleting Comments/Notes:
Right-click the cell with the comment or note and select Delete Comment (or Delete Note). To delete all comments/notes in the worksheet, go to the Review tab and click Delete All comments.
3. Reviewing and Managing Comments and Changes
Excel allows you to manage and review comments and changes in a more organized way.
· Go to the Review tab, where you can navigate through the comments using the Next and Previous buttons.
· You can also delete individual comments or all comments in the workbook from this tab.
Managing Changes and Comments Together:
· You can see changes and comments in a side-by-side view by opening the Review tab and clicking Show All Comments and using the Track Changes feature simultaneously.
· To get a summary of the changes and comments, you can use the Compare and Merge Workbooks feature in Excel, which allows you to compare different versions of the same workbook, showing both the changes and comments added by different users.
4. Using Excel Online or Shared Workbooks for Collaborative Tracking
In Excel Online (or when using a workbook stored in OneDrive or SharePoint), multiple users can edit the same document at once. All changes are tracked automatically, and Excel provides a visual indicator for the changes made by each user.
· Real-time Collaboration: You can see changes made by others in real-time and communicate using Comments in the Comments pane.
· Version History: Excel Online allows you to view the version history of a workbook. This shows who made changes, when, and what the previous versions of the document contained. You can restore older versions if necessary.


5. Limitations and Considerations
· Track Changes Feature in Shared Workbooks: The Track Changes feature is not available in Excel for Mac or in newer versions of Excel, as Excel Online or Excel 365 has replaced it with real-time collaboration.
· Comments vs. Notes: In newer versions of Excel, Comments are used for threaded discussions, while Notes are used for traditional single-line annotations. This distinction can be confusing, so it's important to know which feature you’re using.
· Password-Protected Workbooks: If you are using password protection for your workbook, you must remove the protection before tracking changes, as Excel may not allow changes in a protected workbook.
[bookmark: _Toc183084601]Macros and Automation
A macro is essentially a series of Excel commands or actions that you can record, save, and play back later. Macros can automate tasks like formatting cells, inserting rows, running calculations, and even more complex processes.
How to Record a Macro:
· Open the Developer Tab (if not visible)
· Go to the File tab → Options.
· In the Excel Options dialog, select Customize Ribbon.
· In the right column, check the box next to Developer to enable the Developer tab, then click OK.
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Start Recording the Macro:
· Go to the Developer tab and click Record Macro.
· In the Record Macro dialog box:
· Name the Macro: Provide a descriptive name for your macro (no spaces allowed).
· Shortcut Key: You can assign a shortcut key for easy access (e.g., Ctrl + Shift + A).
· Store the Macro In: Choose where to save the macro:
· This Workbook: Saves the macro only in the current workbook.
· New Workbook: Saves the macro in a new workbook.
· Personal Macro Workbook: Saves the macro in a hidden workbook that opens automatically whenever you start Excel.
· Description (optional): You can add a description of the macro. Click OK to start recording.
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Now, perform the actions you want to automate. Excel will record each click, selection, and change you make. For example, you can format cells, enter data, or sort information.
Stop Recording: Once completed , go back to the Developer tab and click Stop Recording.
How to Run a Recorded Macro:
· Run from the Developer Tab, Go to the Developer tab and click Macros.
· In the Macro dialog box, select the macro you want to run and click Run.
Run Using the Shortcut Key: If you assigned a shortcut key, you can simply press the key combination (e.g., Ctrl + Shift + A) to run the macro.
Run from the Macro Button:
You can also add a button to your worksheet that will run the macro when clicked:
· Go to Developer → Insert → Button (Form Control).
· Draw the button on the worksheet, and in the dialog box, assign the macro to the button.
· Click OK, and now you can run the macro by clicking the button.
Editing and Deleting a Macro:
To Edit a Macro:
Go to the Developer tab and click Macros. Select the macro you want to edit and click Edit. This will open the VBA editor where you can modify the code.
To Delete a Macro:
In the Macros dialog, select the macro and click Delete.

[bookmark: _Toc183084602]Introduction to VBA (Visual Basic for Applications)
VBA (Visual Basic for Applications) is a programming language developed by Microsoft for automation in Excel and other Office applications. With VBA, you can create custom functions, automate complex tasks, interact with other Office applications, and build advanced user interfaces.
VBA allows you to write code that can control Excel’s behavior, manipulate data, create forms, and interact with other applications. The VBA editor in Excel is where you write and modify your custom code.
Accessing the VBA Editor:
· Go to the Developer tab. Click Visual Basic (or press Alt + F11) to open the VBA Editor.
· In the VBA editor, you can create, edit, and run your macros.
VBA Editor Components:
· Project Explorer: Lists all open workbooks and their associated VBA projects (modules, forms, etc.).
· Code Window: Where you write and edit your VBA code.
· Immediate Window: Used for testing individual lines of code and debugging.
· Properties Window: Displays properties of selected objects.
[image: A screenshot of a computer

Description automatically generated]
Basic Structure of VBA Code:
Sub Procedures:
A Sub Procedure (short for "subroutine") is a block of code that performs a specific task. Each macro in Excel is a sub procedure.
Example of a basic Sub procedure:
[image: Try It Now]
Sub MyMacro()
    MsgBox "Hello, World!"
End Sub
This macro displays a message box with the text "Hello, World!" when run.
Dim (Declare Variables):
Variables are used to store values that can be used later in the code.
Example:
[image: Try It Now]
Sub SumNumbers()
    Dim total As Double
    total = 5 + 10
    MsgBox total
End Sub
This macro adds 5 and 10, stores the result in a variable called total, and then displays the result.
Looping:
VBA allows you to perform repetitive tasks with loops.
Example of a For Loop:
[image: Try It Now]
Sub SumNumbers()
    Dim i As Integer
    Dim total As Integer
    total = 0
    For i = 1 To 10
        total = total + i
    Next i
    MsgBox total
End Sub
This macro sums the numbers from 1 to 10 and displays the result.
If Statements:
Use If...Then statements to execute code based on conditions.
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Sub CheckValue()
    If Range("A1").Value > 100 Then
        MsgBox "Value is greater than 100"
    Else
        MsgBox "Value is less than or equal to 100"
    End If
End Sub
This macro checks if the value in cell A1 is greater than 100 and displays a message accordingly.
Common VBA Operations:
Manipulating Excel Data: You can write VBA code to manipulate data in cells, ranges, or entire worksheets. Example:
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Sub FormatCell()
    Range("A1").Value = "Hello"
    Range("A1").Font.Bold = True
    Range("A1").Interior.Color = RGB(255, 255, 0)
End Sub
This macro sets the value of cell A1 to "Hello", makes the text bold, and changes the background color to yellow.
Interacting with Other Applications: VBA can be used to interact with other Microsoft Office applications like Outlook, Word, and Access.
User Forms: Create custom forms for user input and interaction in your Excel workbooks using VBA.
Debugging and Error Handling in VBA:
Debugging: In the VBA editor, you can step through your code one line at a time to identify errors using the Step Into (F8) feature.
Error Handling: Use On Error statements to handle runtime errors gracefully. Example:
[image: Try It Now]
On Error Resume Next
' code that may cause an error
If Err.Number <> 0 Then
    MsgBox "An error occurred: " & Err.Description
End If

3. Benefits of Using Macros and VBA
Time-saving: Automate repetitive tasks, reducing the time spent on manual operations.
Consistency: Eliminate human error by performing tasks exactly the same way every time.
Advanced Customization: VBA allows you to build custom solutions beyond what’s possible with standard Excel functions and formulas.
Collaboration: Share macros with others so they can automate tasks without needing to know how to write VBA code.





[bookmark: _Toc183084603]Advanced keyboard shortcuts 
Navigating the Worksheet:
· Ctrl + Arrow Key: Jump to the edge of the data in the direction of the arrow (up, down, left, or right).
· Ctrl + Home: Jump to the beginning of the worksheet (cell A1).
· Ctrl + End: Jump to the last cell with data in the worksheet.
· Page Up / Page Down: Move one screen up or down within the worksheet.
· Alt + Page Up / Page Down: Scroll horizontally (left/right) by one screen.
Selecting Cells:
· Shift + Space: Select the entire row of the current active cell.
· Ctrl + Space: Select the entire column of the current active cell.
· Ctrl + Shift + Arrow Key: Select all cells from the current position to the edge of the data.
· Ctrl + A: Select all cells in the worksheet or range (can be pressed multiple times for varying selection scopes).
Working with Rows and Columns:
· Ctrl + Shift + "+": Insert a new row or column at the selected position.
· Ctrl + "-": Delete the selected row or column.
· Alt + E, S, V: Paste Special options menu.
· Ctrl + Shift + L: Turn on/off filters for the selected columns.
Editing and Formatting:
· Ctrl + C / Ctrl + X / Ctrl + V: Copy, Cut, and Paste.
· Ctrl + Z / Ctrl + Y: Undo or Redo the last action.
· Ctrl + B / Ctrl + I / Ctrl + U: Bold, Italic, and Underline.
· Ctrl + 1: Open the Format Cells dialog box.
· Ctrl + Shift + $: Format as currency.
· Ctrl + Shift + %: Format as percentage.
Working with Data:
· Alt + D, P: Open the PivotTable wizard.
· Ctrl + Shift + T: Add a table to the current selection.
· Ctrl + Shift + F3: Open the Name Manager.
· Ctrl + T: Convert the selected range into a table.
Formulas and Functions:
· Alt + "=": Insert the AutoSum formula (quick sum of numbers in the column or row).
· Ctrl + Shift + Enter: Enter an array formula (in older Excel versions).
· F3: Paste a defined name into a formula.
· Ctrl + ~ (Tilde): Toggle between showing formulas and the results in the cells.
· Alt + M, U: Open the Name Manager for managing defined names.

[bookmark: _Toc183084604]Cool Productivity Tools in Excel
Power Query - a powerful tool in Excel used to transform, clean, and load data. It’s great for automating the process of importing and shaping data from various sources (e.g., databases, text files, web pages).
· Getting Data: Go to Data → Get Data to import data from external sources.
· Data Transformation: Use the Transform Data button to open the Power Query editor, where you can remove duplicates, filter rows, and apply transformations to your data before loading it into the worksheet.
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Flash Fill - a tool that automatically fills in values based on a pattern you specify, saving time when working with text data (e.g., splitting names into first and last names). Using Flash Fill: Start typing a pattern, and Excel will suggest the rest. Press Ctrl + E to accept the suggestion.
Data Validation - used to control the type of data entered into a cell. It’s particularly useful for ensuring consistency and accuracy.
· Creating Drop-down Lists: Go to Data → Data Validation → Allow → List to create a drop-down list.
· Input Messages and Error Alerts: You can customize input messages and error alerts to guide users on what data to enter.
Conditional Formatting - allows you to apply formatting (such as colour scales, data bars, or icon sets) based on the values of cells. Conditional Formatting Rules: Go to Home → Conditional Formatting and choose a rule (e.g., colour scales, highlight cells based on criteria, etc.).
Sparklines - are tiny charts that fit into a single cell and represent data trends visually. They are useful for quick visual analysis of data over time. Creating Sparklines: Go to Insert → Sparklines to add line, column, or win/loss sparklines to your data.
[image: ]
	[image: Try It Now]
	Try out all of the above productivity tools!





Congratulations on completing this Level 2 Excel course! 
You are now well equipped to create amazing business spreadsheets…..
…. keep practicing to really perfect those new skills!

[image: ]


Want to learn more? 
Enrol in another of our other short courses:
Microsoft PowerPoint – Level 1	
Microsoft Outlook – Level 1	
Microsoft OneNote – Level 1	
Microsoft Teams – Level 1	
Sales Week 1

Fidget Widgets	Total Sales	162	Widget 1	Total Sales	473	Widget 2	Total Sales	272	Widget 3	Total Sales	44	Deluxe Widgets	Total Sales	128	









Sum of Price	Headphones	Laptop	Smartphone	Smartwatch	Tablet	100	1200	500	250	600	Sum of Stock Levels	Headphones	Laptop	Smartphone	Smartwatch	Tablet	200	50	120	80	75	



Page 2 of 2

image2.png
a =
The Ribbons hd
He lome et Poeloms Fomdss Oun Reiew View Adomate Hep & Conmers| (RN
é, forntaron v 3 o Bwerren et B RD BRE é:«rim‘
N Beacon + | § - % 9% | St o G2 | v ove tema | D%
€ ¢ 6 w14 x L wm w o » o & s 1 _u v w4
Worksheet area
s
o Status Bar Adjust views & Scrolling bars
H
= E
son 4 «
sty [T ety ot

[T R T I S———





image3.png




image4.png
File  Home Insert Pagelayout Formulas Data Review View Automate Help

E"'D [Mut [AptosNarow |1 < A° A7 v BwepTet

Copy + [
Paste gF Py ; B I U-~H- &vA- erge & Centre
- ormat Panter

Clipboard ® Font 5 Alignment

4
s
6
7
B
9




image5.png
File  Home Insert Pagelayout Formuas Data  Review

f" X cut (Aptos A A
[@copy ~
vm@"y B I U« A
v < Format Painter
Cipboara 5 Font 5
3 . |z fi~ =OR(AL < 10, B1 > 100)
A 5 c o e
8 7 Not Qualified
65 18 FALSE

7 2 TRUE




image6.png
Data

Apples

Bananas

Formula

=INDEX(A2:83,2,2)

=INDEX(A2:83,2,1)

Lemons

Description

Value at the intersection of the second row and second column in the
range A2B3.

Value at the intersection of the second row and first column in the range
A2B3.

Result

Pears

Bananas




image7.jpeg
D10~ £ Iﬁuwkonucﬂ(n B87=B10)*(C2:C7=C10)*D2: D7;|

A B c D E F
Item Size Sold|
X

© e N g s W N -
N= % N<

item  Size Total

3





image8.png
& Autosae

ivity_with_Instructions
File  Home Insert Page Layout Fory View  Automate  Help
[T Queries & Connections.
GhDhHE B W [
From  From FromTable/ From Recent = Bisting  Refresh
P Range  Picture~ Sources Comnections  All~  [%)
Get & Transform Data
- -

Queries & Connections

0
Sods coences

Data Types

P search

[

Geography [7]

o itter
z| st Fi

2 Advanced
sortaiter

Textto
Columns

=
=S

Data

Data Tools

Cor

[

idate

Data

Model ~

@ 5 B

What-If ~Forecast
Analysis~  Sheet

Forecast

Gr




image9.png
aa@:

Y S == =
o e Tetto Fash Remove | Daa  Coffolicate Dota W
2 Advanced | Columns  Fil  Duplicates alidation Model~  An:
Sort & Fiter D3 Tools
[ N ) [ a R s i
Data Valicatig 7%
setings o Alert
8 show g cellis selected
When cell s slected,show his put messoge:
Tt
Input message:

Clear Al





image10.png
& Autosae

File  Home Insert Pagelayout Formulas Data Review

GhDHBDL

From  From FromTable/ From  Recent
baa Ted/CSV Web  Range  Picture~ Sources

Get & Transform Data

fe Product Name

[ c
Product Name _|Price. Stock Levels

smartphone 500 120}
Laptop 1200 £
Headphones 100 200
smartwatch 250 20|
[Tablet 600 5]

(b

Bxisting
Connections

DB 9D~ ¢ = PivotTable Activity_with In

I

Ref
Al




image11.png
& aosae (@ ) H 9~ < PivotTable_Activity with Instructions v £ search ® - o x
Fle Home Insert Pagelayout Formulas Data Review View Automate Help  PivotTable Analyse Design [+ comments |
PivotTable Name: | Active Field: B = [ I = =] = e
R - = BEE RC-= B B [EEE
(PvotTablel  J| (ProductName | - Insert _Insert Refresh ChangeData | Clear Select Move | Fields,fems, PivotChart Recommended | Field || +/- || Field
[ options ~ | 2 - il Sicer Timeline v Sourcev v v Pvotble  &Sets~ Pivotfables | Lit | Buttons|Headers
Protrable Adive Field Group Fiter Data Adions Catcutations Tools T show ~
F12 v fi| Rowlabels v
A 8 c ) 3 3 I H ! ] 3 L ™ N o 3 a R s T u
1 [Steps to create PivotTable: PivotTable Fields
2 |1. Select the dataset from the 'Data’ sheet. Choose feds o dd o repor
3 |2.Go tothe Insert tab and select PivotTable.
4 [3. Choose where to place the PivotTable (use this sheet). ED
5 |4. Add Product Name' to Rows, Price to Values, and ‘Stock Levels' to Values.
o s Apply ilters or slicers as needed. = e
g [ rice
9 [ Stock Levels
0 More Tables...
1
2 Row Labels | - |Sum of Price Sum of Stock Levels.
3 Headphones 100 200
4 Laptop. 1200 50
5 Smartphone 500 120
5 Smartwateh 250 50
7 Tablet 500 7
5 Grand Total 2650 525
5
0
1
” Drag filds between areas below:
2 Y Fiters 1l Columns
4
s
5
7
]
3
0
i 3 Values
2
3 ProductName v ||| Sum of Price .
4
s Sum of Stock Levels
3
7
8
3 v
< > Data + [7] Defer Layout Update





image12.png
e Home Insert Pagelayout Formulas Data
sl B BR b
From  From FromTable/ From Recent = Existing
o TS e Range  Picture~ Sources Connections
Get & Transform Data
- Je || ProductName
A s c )
oroduct Name___!Price Stock Levels
martphone 500 120
aptop 1200 50
ieadphones 100 200
martwatch 250 0
ablet 600 7

Review

View  Automate  Help

’rL [T Queries & Connections

B

Queries & Connections

2 =
5 =
iy @ o N B A B =
com C 2 ecncaty Fiter | Textto Remove  Data
o Curences Geogrphy [7] advnced | Cotmns 11| Dupliote Valdatan~
oatapes sonariter et Toots
, s « . m N ° 3 a ® s

Goal Seek.
setcel
Toalue:

By changing cell:

Be

Consolidate

&

557

What-If Forfcast
Analysis~  Sffeet

8 8 |

Group Ungroup S

Forecs Outiine




image13.png
@ avosse @ D H 9~ = PivotTable Acivity with Instructions v

T o D GEgm Gt o B
o B
¥ B B G S5 B 89

Spelling Thesaurus Workbook ~ Check Check. Smart  Tanslate New
Statistics | Performance | Accessibility ~  Lookup Comment

Proofing Performance | Accessibiliy  Insights | Languag:

Hs v o Ay
A [ c D E E G

S v

Comments

P search

]

Show
Comments

o

Notes

Notes

B B

Protect Protect

Sheet Workbogk

&

Allow Edit

i




image14.png
File  Home Insert Pagelayout Formulas Data Review View Automate Help

*EE B L O% B 000D DERDER

Proofing Performance | Accessibiliy Insights | Language  Changes Notes protect Ink




image15.png
File  Home Insert Pagelayout Formulas Data Review View Automate Help

@ E B B O% OO0 00 DA

Speling Thesauus Workbook | Crece e St Tandate New Show | Newws | pr
Soisis | perormance | Accesinly < | Lookup Comment Comments o S
roting betomance | Aceslly | nsigis | Langusge  Cranges Comments ot
H5 o |i fov
A s c > e F e ! ) « .

L Product Name Pr Stock Levels Date:
) |smartphone
; |Laptop vcel Optons ) 7 x
 Headphones
5 |smartwatch General [‘\

=2 Customise the Ribbon.
5 [Tablet . |
! Choose commands from: © Customise the Ripbon: ©
g osa

[ Popular Commands [ MainTabs B
) Proofing
3
7 sove (P AddorRermove Fies N S@reseLoron D
5 e DA Chart pes.. [rsteChard e

oo
3 e >@Data

— csteNow
2 y 2‘("“ N B Review
5 A~ entre > Proofing
= p [ElConditional Formatting > S
S —— co
7 < Custormie Rion Ecory o
s S— e
> NN hoa e
3 A Decrease Font Size S anaunae
. RIS FEpelete el g
; st Cnter Hpscesne columns iz
3 < eleteShet R e
3 e
2 |2Fi Colour
o
s
2 | Font Colur
oS

s
2 ] Format el
: (Srometpaer o
; e Pones , ‘
] s Foisze  Rename-
: SHsen el
2 it [
2 meetBeet
6 Conce
g - - - - -




image16.png
Visual Macros
Basic

A Moo Securiy
code

ayout

Formulas  Data

Review

com

OB
c

o
E5 b
et

:

Cancel

FL ~ v
A >\

1 [Product Narf ¢ ord Mo

2 |smartphon

3 Laptop

4 Headphones st

5 |smartwatch

6 Tablet Shortct ey

7 cute

3 Store macro

9

5 This Workbook

2 Descripton:

2

5

4

5

6

17

8

5




image17.png
t| Microsoft Visual Basic for Applications - PivotTable_Activity_with_Instructions.xlsx [break]

ile Edit View Insert Format Debug Run Tools Add-Ins Window Help

Bvd $2a@mam9 e » o a BEFY =@ nocot

EEIR

&= @VBAProjed: (PivotTable_Activity_with_Instructions.xl...)
(=25 Microsoft Excel Objects

Sheet1 (Data) f:‘ub mcrTest ()

Sheet2 (PivotTable Instructions) B

%jThE“mﬂdnok Y

[=}-5 Modules

% Module1 Keyboard Shortcut: Ctrl+t

‘(General) v ‘ ‘mchraclice

mcrTest Macro
testing

End Sub

' mcrPractice Macro

Practice macros
Keyboard Shortcut: Ctrl+p

Range ("A9") .Select
ActiveCell.FormulaR1Cl = "this is for practice"
Range ("A10") .Select

End Sub

Modulel Module

Alphabetic  Categorized
(Name)\ModuIel





image18.png
M| @ - < | Power Query Editor

|
. T - || A W - é
ﬁ'_j DD Properties ===t Zl F _‘ % Data Type: E‘_ [
[Er Advanced Editor ,Z\l [ Use First Row as Headers ~ [
Close &  Refresh = Manage Reduce Split Group Combine  Manage Data source :
Load~  Preview ¥ idapags Columns ¥ Rows ¥ Column~ By gulieplacaiialies e Parameters ¥ settings
Sort Transform Parameters  Data Sources

Close Query

Queries ]




image19.png
File  Home

Insert Page Layout Formulas Data Review View Automate Developer Help Sparkiine
% [ | | Osvem  Orisoan
Edit Line |Column| winy | L LowPoint [0 Last Point
Data Loss
Sparkline

] NegtivePoints
Type

Show

2 Sparkine Colour -

[ Marker Colour ~ w

Ais

style

O cior -

Group




image20.png




image1.png
— CHARLES
DARWIN
UNIVERSITY

< AUSTRALIA

You make CDU




